Kunena ei suostu tallentamaan liitteitä

Lisää
27.05.2016 19:08 #8300 : Mortti
Mortti vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
Äkkiseltään en kyllä keksi, mikä sen aiheuttaa, pikaisesti vain vilkaisin noita asetuksia, eikä näyttänyt olevan pahemmin ristiriitoja. Näetkö joomlan tai serverin error logista mitä tuolloin tapahtuu ja mitä ilmoittaa vai ilmoittaako mitään?

Finnish Joomla! Language Coordinator | One of the guys behind Joomla.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
28.05.2016 02:45 #8301 : Mortti
Mortti vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
Voisiko olla niin, että Jevents -lisäosa blokkaa tätä nykyää Kunenaa? (luulis molempien olevan yhteensopivia keskenään), lähdekoodin perusteella tämä voisi olla mahdollista ehkä, en tiedä... en näe foorumia kun on suljettuja jos ei oo rekisteroitynyt/kirjautunut.

Kannattaa katsoa aluksi Joomlan error -logi, joka siis löytyy sivutilan juuresta. Palvelin palveluntarjoaja tarjoaa(palvelintarjoaja auttaa asiakasta) syvemmän tiedon pyydettäessä...

ps. näytti siltä, että Kunena vitonen on tuloillaan, täytyis taas hieman kirjoitella/kääntää ku keretään jossain vaiheessa, vai mitä...

Finnish Joomla! Language Coordinator | One of the guys behind Joomla.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • TeroKankaanpera
  • TeroKankaanpera hahmo Aiheen kirjoittaja
  • Poissa
  • Valvoja
  • Valvoja
  • JEvents, J2Store 3 ja AdsManager kääntäjä
Lisää
28.05.2016 09:49 #8303 : TeroKankaanpera
TeroKankaanpera vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
Melko kryptinen on mut tässä lisää tiedonmuruja:

1. Yllättäen liitetiedostot kyllä siirtyvät palvelimelle ja löytyvät /images/kunena/attachements -alikansioista (käyttäjän id:n mukaan).

2. cPanelin Error logista löytyy tällaista jälkeä:
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecopyresized() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 143, referer: http://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagefill() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 130, referer: http://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecolortransparent() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 129, referer: http://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecolorallocatealpha() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 125, referer: http://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagesavealpha() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 106, referer: http://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagealphablending() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 105, referer: http://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecreatetruecolor(): Invalid image dimensions in /home/fortisf/public_html/libraries/kunena/image/image.php on line 72, referer: http://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  Division by zero in /home/fortisf/public_html/libraries/joomla/image/image.php on line 1079, referer: http://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  Division by zero in /home/fortisf/public_html/libraries/joomla/image/image.php on line 1078, referer: http://fortis.fi/foorumi/testaus/topic/create
Ymmärtääkseni Warning-tasoisen virheen ei kuitenkaan pitäisi johtaa näin vakaviin ongelmiin.

Googlailu ei tuota yhtään mitään tähän liittyvää. Olen myös ajanut Admin Toolsin Optimize and repair tables -tietokannalle. Joomlan debug-toiminnon tai kehitys/tarkin -virheilmoitustason käyttöönotto sivustolla ei paljasta mitään. Näyttää tosiaan siltä että jotain tapahtuu internal hand off -prosesissa palvelimella joten pitää yrittää saada Neobitistä irti jotain tolkullista tietoa.

Missäs hapessa toi Kunena projekti muuten on? Näyttää pahalta miten vanhaa tietoa sivuilla on. Ainoa elonmerkki ovat 5 version julkaisublogit mutta sekin julkaisu on nyt RC:n ja julkaisun verran myöhässä.

---
Tero Kankaanperä
terokankaanpera.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
28.05.2016 19:23 - 28.05.2016 19:23 #8305 : quietFinn
quietFinn vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
Varoitukset (warn) ei tosiaan pitäisi aiheuttaa varsinaisia ongelmia, yleensä isoin ongelma on se että error_log saattaa kasvaa tosi suureksi jolloin levytila täyttyy.

Nuo varoitukset johtuvat yleensä siitä että Joomla tai joku sen lisäosa ei toimi oikein käytössä olevalla PHP versiolla.

Jos PHP versiota pystyy vaihtamaan niin kannattaisi kokeilla toimiiko PHP 5.4 tai 5.3 versiolla.

netFinn - Taatusti Joomla!-yhteensopiva webhosting: www.netfinn.fi
Last Edit: 28.05.2016 19:23 : quietFinn.

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • TeroKankaanpera
  • TeroKankaanpera hahmo Aiheen kirjoittaja
  • Poissa
  • Valvoja
  • Valvoja
  • JEvents, J2Store 3 ja AdsManager kääntäjä
Lisää
28.05.2016 19:40 #8306 : TeroKankaanpera
TeroKankaanpera vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
PHP version pystyy vaihtamaan vain vanhempaan 5.3:een, jota käytössä olevista muista lisäosista jotkin eivät enää tue. Neobitti on vähän kökkö. :(

---
Tero Kankaanperä
terokankaanpera.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
30.05.2016 06:03 #8308 : Mortti
Mortti vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
Hei, huomasin yhden eroavaisuuden asetuksissasi kun vertasin testisivustoni asetuksia, joka saattaisi olla syypää tai sitähän tuossa huomautuksessa herjataan?
Eli mene Asetukset --> Julkisivu --> Category Legacy Image Path

Vaihda tuo "category_images/" muotoon "category_images"...

Finnish Joomla! Language Coordinator | One of the guys behind Joomla.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • TeroKankaanpera
  • TeroKankaanpera hahmo Aiheen kirjoittaja
  • Poissa
  • Valvoja
  • Valvoja
  • JEvents, J2Store 3 ja AdsManager kääntäjä
Lisää
30.05.2016 09:12 #8309 : TeroKankaanpera
TeroKankaanpera vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
Toihan on vain kategorioiden tunnuskuville, ei liitteille. Tunnuskuvia ei ole käytössä yhdelläkään foorumialueella joten on epätodennäköistä että sillä on vaikutusta. Pitää kuitenkin kokeilla kun Kunenan oma foorumikaan ei ole tuottanut pariin päivään ainuttakaan vastausta. :(

---
Tero Kankaanperä
terokankaanpera.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • TeroKankaanpera
  • TeroKankaanpera hahmo Aiheen kirjoittaja
  • Poissa
  • Valvoja
  • Valvoja
  • JEvents, J2Store 3 ja AdsManager kääntäjä
Lisää
30.05.2016 11:40 #8311 : TeroKankaanpera
TeroKankaanpera vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
Joo, ei ollut vaikutusta category_image-asetuksella.

Mut kikkaileminen sivupohjilla (sivustolle erillisen sivupohjan asettaminen foorumin valikkokohdille ja Kunenan sivupohjan vaihtaminen) tarjoaa vaihtoehtoisen virheilmoituksen:

No valid image was loaded.

Mutta yhtään enempää informatiivinen tämä ei ole. Yritetyt kuvat ovat alle koko rajoituksen ja hyväksyttyä tyyppiä.

---
Tero Kankaanperä
terokankaanpera.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • TeroKankaanpera
  • TeroKankaanpera hahmo Aiheen kirjoittaja
  • Poissa
  • Valvoja
  • Valvoja
  • JEvents, J2Store 3 ja AdsManager kääntäjä
Lisää
31.05.2016 09:03 #8315 : TeroKankaanpera
TeroKankaanpera vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
Jelle Kok on asian kimpussa, hänellä on nyt sivuston ammattituelle tekemämme tunnukset joilla ihmetellä ongelmaa "paikan päällä".
Kunena foorumin resident besserwisser sotkee välissä lukematta viestiketjua alusta alkaen ja sotkeutuen lillukanvarsiin. FPA liittyy juttuun niin että yritin täydentää tietoja ympäristössä Forum Post Assistant raportilla joka ei mene Kunenan tukifoorumille läpi ("too many links", = nolla). Tuo Kunenan oma asetusraporttihan on selvästi suppeampi.
Olen tässä välissä varmistanut ettei Admin Toolsin tietoturvallisempi htaccess tai WAF Uploadshield ole ongelman syynä.
Olen myös käynyt tiheällä kammalla läpi tiedostojen lataukset Joomlaan ja Kunenaan (päätteet ja mime-tyypit).
Jokin on prosessissa muuttunut: aluksi mitkään liitteet eivät menneet läpi, nyt pdf ja muut ei-kuvaliitteet toimivat. Näyttäisikin siltä että ongelma on siinä mitä kuvatiedostolle tapahtuu kun sellainen liitetään Kunenaan. Kunena ilmeisesti syöttää sen ketjuun palvelimen php:n kuvankäsittelyliitännäisiä jotka muokkaavat sen kokoa ja tämä ketju on rikki (tai jotain). SVG-tiedostoilla on vielä joku ihan oma ongelmansa mutta se tuskin yllättää ketään niitä verkkopalveluihin syöttäneitä.
Viestiketju Kunenan foorumilla: www.kunena.org/forum/kunena-support-reporting-defe...ching-uploaded-attachment-file

---
Tero Kankaanperä
terokankaanpera.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
31.05.2016 10:06 #8321 : Mortti
Mortti vastasi aiheeseen: Kunena ei suostu tallentamaan liitteitä
Jelle on mies paikallaan, erittäin asiantunteva, yksi nykyisistä pääkehittäjistä. Se että miksi silloin ehdotin sitä yhtä kenoviivan postoa, johtui siitä, että sitä ei enää ollutkaan tuoreella testisaitilla, tuo on jossain vaiheessa muuttunut kai, jolloin polku lisätty suoraan koodiin, koska oli aikoinaan kenoviivalla, mutta miksi ei ole päivittynyt asetuksiisi päivityksen yhteydessä...? en tiedä?

Onko sulla mitään mahdollisuutta ottaa sivuston täysi copy ja yrittää samaa asiaa esim. paikallisella serverillä, jossa PHP muu kuin kyseinen 5.5.3...?

Meitin Arto puhuu yleensä vähän, mutta asiaa:

Jos PHP versiota pystyy vaihtamaan niin kannattaisi kokeilla toimiiko PHP 5.4 tai 5.3 versiolla.


Finnish Joomla! Language Coordinator | One of the guys behind Joomla.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Valvojat: jkwebdesignGamossJiiKoo
Sivu luotiin ajassa: 0.035 sekuntia