Päivitys 3.7.5 -> 3.8.0

  • MrMaikkeli
  • MrMaikkeli hahmo Aiheen kirjoittaja
  • Poissa
  • Jäsen
  • Jäsen
Lisää
19.09.2017 20:54 #8971 : MrMaikkeli
MrMaikkeli loi aiheen: Päivitys 3.7.5 -> 3.8.0
Onko muilla käynyt vastaavaa? Kun asensin päivityksen, adminissa ei näy muuta kuin yläpalkki ja sivuotsikossa: Virhe 0 call to undefined method JAdminCssMenu::addChild()

Ja palkissa näkyy teksti: Error displaying the error page
Mitenkä tuon sais korjattua?

"Lupaan olla piereskelemättä ruokapöydässä jos sinä lupaat olla jeesustelematta"
Liitetiedostot:

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
22.09.2017 10:39 #8975 : Gamoss
Gamoss vastasi aiheeseen: Päivitys 3.7.5 -> 3.8.0
vastaavaa ongelmaa löytyi lontoon kieliseltä foorumilta:

www.joomshaper.com/forums/error-0-call-to-undefined-method-jadmincssmenu-addchild

Onko kenties jotain menu moduulia käytössä sivustolla mikä jumittaa sivuston?

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
22.09.2017 12:59 #8976 : Kartsa
Kartsa vastasi aiheeseen: Päivitys 3.7.5 -> 3.8.0
Minulla lakkasi template JSN Groove pro toimimasta kun päivitin 3.7.5. -> 3.8.0. Piti palauttaa varmuuskopiosta 3.7.5

Onko ehdotuksia korjaussarjoista? Template on reippaasti räätälöity joten mielellään en lähtisi uutta templatea siihen laittamaan.

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
22.09.2017 14:05 #8977 : Kartsa
Kartsa vastasi aiheeseen: Päivitys 3.7.5 -> 3.8.0
Asia korjaantui mystisesti:

Asensin JSN Gruve free templaten ja otin käyttöön. Sitten otin taas käyttöön JSN Gruve Pro:n ja kas kummaa se alkoi toimia. Olin kyllä kokeillut muitakin templateja mutta vasta kun käytin välillä free versiossa niin sain toimimaan.

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
22.09.2017 14:06 #8978 : Gamoss
Gamoss vastasi aiheeseen: Päivitys 3.7.5 -> 3.8.0
Asensitko mahdollisesti päivitetyn version aikaisemmasta sivupohjasta?

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
22.09.2017 14:50 #8979 : Kartsa
Kartsa vastasi aiheeseen: Päivitys 3.7.5 -> 3.8.0
En asentanut päivitettyä sivupohjaa.

Tein saman homman toisellekin sivustolle:
1. Päivitin joomlan 3.8.0 versioon jonka seurauksena ulkoasu meni päreiksi (Refresh tai muukaan ei auta)
2. Asensin JSN Gruve free teeman ja otin käyttöön
3. Otin käyttöön alkuperäisen JSN Gruve Pro teeman jonka jälkeen ulkoasu taas oli kunnossa

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
23.09.2017 07:20 - 23.09.2017 07:21 #8980 : JiiKoo
JiiKoo vastasi aiheeseen: Päivitys 3.7.5 -> 3.8.0
Viimeisimmän päivityksen yhteydessä korostettiin, että lisäosien (myös sivupohjien) pitää olla ajan tasalla. Ehkä tämä linkki ilmenneistä virheilmoituksista selvittää hiukan mistä on kysymys: docs.joomla.org/J3.x:Call_to_undefined_method_JAdminCssMenu::addChild_in_backend

Kokemus on asia, jonka saat heti kun olisit tarvinnut sitä.
jaakko.korhonen(at)jg-oppimiskeskus.fi
Viimeksi muokattu: 23.09.2017 07:21 : JiiKoo.

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • MrMaikkeli
  • MrMaikkeli hahmo Aiheen kirjoittaja
  • Poissa
  • Jäsen
  • Jäsen
Lisää
23.09.2017 12:04 #8981 : MrMaikkeli
MrMaikkeli vastasi aiheeseen: Päivitys 3.7.5 -> 3.8.0
Tämä kyllä oli tiedossa että lisäosat pitää olla päivitettynä ja olikin. Käytän Joomshaperin Helix templatea parilla sivustolla, mutta kuitenkin admin puoli sotkeutu, joten joiduin päivittämään takas 3.7.5

"Lupaan olla piereskelemättä ruokapöydässä jos sinä lupaat olla jeesustelematta"

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
23.09.2017 16:16 #8982 : Kartsa
Kartsa vastasi aiheeseen: Päivitys 3.7.5 -> 3.8.0
Kun olin päivittänyt 3.7.5 sivuston 3.8.0 versioon tuli Louhelta viesti:

Hei,
Olemme havainneet haavoittuvaisuuksia webhotellipakettisi PHP-skripteissä. Haavoittuvaisuuksien hyväksikäytön estämiseksi nämä tulisi korjata mahdollisimman nopeasti. Tämä koskee seuraavia haavoittuvaisuuksia:

Tietojen paljastaminen haavoittuvuus ohjelmassa Joomla
/home/pizzeria/public_html/plugins/authentication/ldap/ldap.php

Joomla administratorin mukaan:
Joomla on ajan tasalla
Kaikki lisäosat ovat ajan tasalla

Täytyy varmaankin päivittää varmuuskopiosta takaisin 3.7.5 koska siitä versiosta ei tullun palveluntarjoajalta viestejä.

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
23.09.2017 21:53 #8983 : Gamoss
Gamoss vastasi aiheeseen: Päivitys 3.7.5 -> 3.8.0
Kysäiseppäs Louhelta varoittivatko oikeasti 3.8 versiosta, koska siinä juurikin fiksattiin Ldappiin liittyvä haavoittuvuus. Nimimerkillä Louhi ei aina ole vakuuttanut...

Core - Information Disclosure in LDAP Authentication Plugin (affecting Joomla 1.5.0 - 3.7.5)

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Valvojat: jkwebdesignGamossJiiKoo
Sivu luotiin ajassa: 0.185 sekuntia