Turvallinen päivitys 1.5.23 -> 2.58

  • sahkari
  • sahkari hahmo Aiheen kirjoittaja
  • Poissa
  • Tulokas
  • Tulokas
Lisää
03.12.2012 14:13 #3964 : sahkari
sahkari loi aiheen: Turvallinen päivitys 1.5.23 -> 2.58
Eli sivusto mitä olen päivitellyt käyttää vanhaa 1.5.23 versiota joomlasta, niin mikä olisi turvallisin tapa päivittää sivusto uusimpaan versioon?

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • mirkoe
  • mirkoe hahmo
  • Poissa
  • Ylläpitäjä
  • Ylläpitäjä
  • Kahvilla pärjää aina!
Lisää
03.12.2012 14:59 #3965 : mirkoe
mirkoe vastasi aiheeseen: Turvallinen päivitys 1.5.23 -> 2.58
Sinun tulee nyt ensiksi päivittää 1.5.23 -> 1.5.26 versioon joka on 1.5 sarjan uusin versio. Hyppy Joomla 1.5 versiosta 2.5 versioon vaatii migraation. Tähän löytyy hyviä työkaluja ja ohjeita netistä, mutta prosessi vaatii myös hieman osaamista. Varsinkin jos sivullasi on paljon lisäosia ja muuta sisältöä kuin Joomlan "perussisältöä". Myös sivupohjaan joutuu todennäköisesti tekemään muutoksia.

Kannattaa aloittaa vaikka tästä ohjeesta

www.joomla.fi/ohjeita/miten-migraatio-tehdaan

Ensiksi kuitenkin varmuuskopiot kuntoon.

Jos se on Joomlalla, teemme sen - www.clicker.fi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • n1k0
  • n1k0 hahmo
  • Vieras
  • Vieras
18.01.2013 13:07 #4303 : n1k0
n1k0 vastasi aiheeseen: Turvallinen päivitys 1.5.23 -> 2.58
Onko mahdollista, että tuo migraatio 1.5.26:sta 2.5:een kestää (jos artikkeleita on muutama tuhat) esimerkiksi yli viisi tuntia? Jos, niin ilmeisesti kuitenkin jupgrader pystyy pitämään istunnon auki niin kauan, kun sillä siihen hommaan menee aikaa?

Annoin nimittäin jUpgraderin tehdä työtään viiden-kuuden tunnin ajan, mutta edelleen oli prosessi kesken, eikä etenemistä ilmoitettu. Oli sitten siirtynyt uuteen Joomlaan kronologisessa järjestyksessä suuri määrä artikkeleita, mutta ei v. 2011 tuoreempia. Loppupäässä oli tolkuton määrä artikkeleita, joita ei voinut avata eikä niillä ollut nimeä.

Neuvot ovat kovin tervetulleita, vanha 1.5-Joomla nimittäin hakkeroitiin, eikä julkiselle puolelle pääse nyt lainkaan.

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • mirkoe
  • mirkoe hahmo
  • Poissa
  • Ylläpitäjä
  • Ylläpitäjä
  • Kahvilla pärjää aina!
Lisää
18.01.2013 13:16 #4304 : mirkoe
mirkoe vastasi aiheeseen: Turvallinen päivitys 1.5.23 -> 2.58
En ole kyllä tuollaiseen törmännyt, enkä usko että noin kauan voi kestää. Mitä itse olen noita päivitellyt, niin tuo Jupgrade on herkkä erilaisille yhteensopimattomuuksille. Esim. rocketthemen jokin lisäosa (en muista mikä) esti kokonaan sen pyörimisen ja paikallispalvelimella se ei meillä pyörinyt lainkaan. Näytti kyllä pyörivän, mutta jumittui juuri kuten sinullakin.

Kannattaa kokeilla Jupgradea myös toisessa ympäristössä jos mahdollista.

Jos se on Joomlalla, teemme sen - www.clicker.fi
Seuraavat käyttäjät sanoivat kiitos: n1k0

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • n1k0
  • n1k0 hahmo
  • Vieras
  • Vieras
18.01.2013 13:21 #4305 : n1k0
n1k0 vastasi aiheeseen: Turvallinen päivitys 1.5.23 -> 2.58
Toisessa ympäristössä testaaminen ei onnistu, mutta kannattaisi siis ilmeisesti ottaa pois kaikki lisäosat? Nehän nyt eivät kuitenkaan vaikuta siihen tekstisisältöön mitenkään.

Se hakkerointi muuten tuottaa seuraavanlaisen tekstin, jos yrittää mennä itse sivustolle:
"Hackeado por HighTech Brazil HackTeam
No\One - CrazyDuck - Otrasher"
Ei tahdo löytyä tietoa siitä, onko tuon poistamiseksi mitään muuta keinoa kuin ilmeisen vaikea päivittäminen 2.5:een; osaatko sinä sanoa?

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • mirkoe
  • mirkoe hahmo
  • Poissa
  • Ylläpitäjä
  • Ylläpitäjä
  • Kahvilla pärjää aina!
Lisää
18.01.2013 13:26 #4306 : mirkoe
mirkoe vastasi aiheeseen: Turvallinen päivitys 1.5.23 -> 2.58
Kyllähän noita keinoja on erilaisia. Voit aloittaa vaikka katsomalla, mitä sucuri.net/ sanoo. Eli skannaa sivustosi tuolla ja katso mitä ilmoittaa. Muut toimenpiteet sitten sen mukaan.

Jos se on Joomlalla, teemme sen - www.clicker.fi
Seuraavat käyttäjät sanoivat kiitos: n1k0

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • n1k0
  • n1k0 hahmo
  • Vieras
  • Vieras
18.01.2013 13:30 #4307 : n1k0
n1k0 vastasi aiheeseen: Turvallinen päivitys 1.5.23 -> 2.58
Sucuri.net ei ilmoita minkään olevan vikana, vaikka siis tuo hakkerointi on tapahtunut ja em. viesti ilmaantuu, jos yrittää sivustolle mennä.

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
19.01.2013 15:24 - 19.01.2013 15:30 #4313 : Pietari
Pietari vastasi aiheeseen: Turvallinen päivitys 1.5.23 -> 2.58
Itsellä kävi myös samalla lailla, jUpgrade jumittui eikä päässyt jatkamaan. Panin debugin päälle. Tässä tekstiä:

Debug

Enable migration debug - In cases where jUpgrade hangs and runs into an error which prevents the process from continuing, setting this to "Yes" will result in a progress log being displayed in a section below the migration steps. The error messages listed here will identify the issue jUpgrade has run into, and the "Troubleshooting" section outlines the solutions for most.
Enable Mootools version debug - If set to "Yes" will ensure a pop-up window appears with the version number of the MooTools library currently loaded every time jUpgrade is accessed. This can be useful in verifying that the required minimum version of 1.2 has been met, although it is not necessary to keep.

wiki.redcomponent.com/index.php?title=jUpgrade:Installing_jUpgrade

P.S. Päiväyksen jälkeen älä käytä admin nimeä ja laita VAHVA salasana! Itsellä on 40 merkkiä ja sisältää jokaisen merkin mitä näppäimistöstä löytyy ja käyttäjänimi on yhtä pitkä. Lataa netistä ilmainen KeePass ohjelma, jolla luot salasanat.
Last Edit: 19.01.2013 15:30 : Pietari.
Seuraavat käyttäjät sanoivat kiitos: n1k0

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
19.01.2013 21:58 - 19.01.2013 22:08 #4314 : Mortti
Mortti vastasi aiheeseen: Turvallinen päivitys 1.5.23 -> 2.58
Muistaakseni mahdolliset jumitukset ja muut errorit johtuvat lisäosasta joka ei ole 2.5 valmis.
Itse ainakin todensin tämän asian kerran kun yksi lisäosa oli jäänyt päivittämättä. Tosin saattaa olla myös lisäosia, jotka ei toimi jUpgraden kaa...

wiki.redcomponent.com/index.php?title=jUpgrade:Ove...w_of_jUpgrade_and_how_it_works

* PHP 5.x
* Curl module of PHP enabled
* Joomla 1.5
* Enable System - Mootools Upgrade plugin that is included in Joomla 1.5.19 and greater.
* A Browser with Javascript/Mootools support

Finnish Joomla! Language Coordinator | One of the guys behind Joomla.fi
Last Edit: 19.01.2013 22:08 : Mortti.
Seuraavat käyttäjät sanoivat kiitos: n1k0

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • n1k0
  • n1k0 hahmo
  • Vieras
  • Vieras
20.01.2013 12:53 #4315 : n1k0
n1k0 vastasi aiheeseen: Turvallinen päivitys 1.5.23 -> 2.58
Laitoin debugin päälle, niin tällaisen virheilmoituksen se nyt antaa:
"Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 8686 bytes) in /xxxxxxx/site/jupgrade/libraries/joomla/database/database.php on line 1455"
(xxxx:n lisäsin toki itse).

Miten tuohon pääsisi käsiksi, onko tietoa?

Kiitokset jälleen vastauksista!

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Valvojat: jkwebdesignGamossJiiKoo
Sivu luotiin ajassa: 0.032 sekuntia