Joomla! 3.9.6 | Sivupohjan vaihtaminen rikkoo front endin (ratkaistu)

  • Waltsu
  • Waltsu hahmo Aiheen kirjoittaja
  • Poissa
  • Tulokas
  • Tulokas
Lisää
31.05.2019 01:43 - 03.06.2019 07:46 #10351 : Waltsu
Waltsu loi aiheen: Joomla! 3.9.6 | Sivupohjan vaihtaminen rikkoo front endin (ratkaistu)
Moro!

Tarkoitus olisi väsätä kaverin firmalle nettisivut. Kuivaharjoitteluna iskin Wampin käyntiin ja asensin Joomlan localhostiin. Opeteltavaa ja muistinvirkistystä on riittänyt, Viimeksi kajonnut Joomlaan, kun versionumero alkoi kakkosella.

Kummallisin tähän mennessä vastaan tullut asia liittyy sivupohjiin. Pystyn vaihtamaan käyttöön perusasennuksen mukana tulleet Beez3 & protostarin ongelmitta. Yrittäessäni vaihtaa Sitegroundista lataamaani ilmaistemplatea käyttöön, menee front end solmuun 0 - Using $this when not in object context Mihin tämä mahtaa liittyä? Yhteensopivuusongelma? Vai kenties jokin itsestäänselvyys, jota en vain tajua. Back end vakuutti minulle asennuksen onnistuneen, eikä erroreita tullut.

Alan epäillä ottaakko koko projektia haltuun, jos en saa edes kolmannelta osapuolelta ladattua sivupohjaa toimimaan.
Last Edit: 03.06.2019 07:46 : JiiKoo. Syy: Merkitty ratkaistuksi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • Waltsu
  • Waltsu hahmo Aiheen kirjoittaja
  • Poissa
  • Tulokas
  • Tulokas
Lisää
31.05.2019 14:16 #10352 : Waltsu
Waltsu vastasi aiheeseen: Joomla! 3.9.6 | Sivupohjan vaihtaminen rikkoo front endin
Ilmeisesti kyseessä ei olekaan yhhteensopivuuteen liittyvä asia. Latasin 3.9 tarkoitetun templaten ja virhe tuntuisi liittyvän index.php:n puuttumiseen.. Kaikki ladatut templatet tekevät tenän. protostar ja Beez3 kuitenkin siis tosiaan toimivat. Pitäneekö tulkita, että ongelma liittyy jotenkin WAMPiin ja localhostiin?

Tältä uusimmalta sivupohjalta hukassa tuntuisi olevan myös layoutcontent.php

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
01.06.2019 10:12 #10353 : JiiKoo
JiiKoo vastasi aiheeseen: Joomla! 3.9.6 | Sivupohjan vaihtaminen rikkoo front endin
Hakulauseella 0 - Using $this when not in object context löytyy useitakin vastauksia. Esim.
forum.joomla.org/viewtopic.php?t=967125
ja
forum.joomla.org/viewtopic.php?t=967125

Kokemus on asia, jonka saat heti kun olisit tarvinnut sitä.
jaakko.korhonen(at)jg-oppimiskeskus.fi
Seuraavat käyttäjät sanoivat kiitos: Waltsu

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

  • Waltsu
  • Waltsu hahmo Aiheen kirjoittaja
  • Poissa
  • Tulokas
  • Tulokas
Lisää
02.06.2019 20:31 - 03.06.2019 07:45 #10354 : Waltsu
Waltsu vastasi aiheeseen: Joomla! 3.9.6 | Sivupohjan vaihtaminen rikkoo front endin (ratkaistu)
Kiitos JiiKoo, suoraan en näillä linkeillä vielä ongelmaa ymmärtänyt, mutta johdatit minut oikeille jäljille! PHP 7.2 tuntuisi olevan "kaiken pahan alku ja juuri" Pudotin WAMPin PHP version 7.1 ja kaikki lataamani sivupohjat lähtivät rokkaamaan!

Jos saan esittää jatkokysymyksiä vielä tähän ketjuun; Mikä PHP versio pyöriii tällä hetkellä suomalaisissa webhotelleissa pääsääntöisesti? Tokihan netistä löytyi ohjeita pohjien saattamiseksi toimimaan muokkaamalla esim. niiden index.php:tä. Mulla ei kuitenkaan ole valtavaa kompetenssiä. PHP:n sutheen. Minun ei siis onnistunut manuaalisesti korjata templateja.

Vielä mielelläni tiedustelisin foorumiväen valintaperusteita sivupohjiksenne. Katselin pohjia olevan myynnissä paljon ja joihinkin näistä hintaan näytti sisältyvän tekninen tuki. Ilmeisesti juuri näitä tilanteita varten. Oletteko ostaneet pohjia, vaiko pärjänneet ilmaisilla.

Mikäli ylläpitö on sitä mieltä, että viimeisin kysymykseni poikkeaa liikaa alkuperäisestä, voin avata uuden aiheen! :)
Last Edit: 03.06.2019 07:45 : JiiKoo. Syy: Merkitty ratkaistuksi

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Lisää
04.06.2019 15:27 #10355 : quietFinn
quietFinn vastasi aiheeseen: Joomla! 3.9.6 | Sivupohjan vaihtaminen rikkoo front endin (ratkaistu)

Waltsu kirjoitti: Jos saan esittää jatkokysymyksiä vielä tähän ketjuun; Mikä PHP versio pyöriii tällä hetkellä suomalaisissa webhotelleissa pääsääntöisesti? Tokihan netistä löytyi ohjeita pohjien saattamiseksi toimimaan muokkaamalla esim. niiden index.php:tä. Mulla ei kuitenkaan ole valtavaa kompetenssiä. PHP:n sutheen. Minun ei siis onnistunut manuaalisesti korjata templateja.


Jos webhotellissa on käytössä cPanel niin silloin PHP version voi (todennäköisesti) asiakas itse valita.

netFinn - Taatusti Joomla!-yhteensopiva webhosting: www.netfinn.fi
Seuraavat käyttäjät sanoivat kiitos: Waltsu

Kirjaudu tai Rekisteröidy liittyäksesi keskusteluun.

Valvojat: jkwebdesignGamossJiiKoo
Sivu luotiin ajassa: 0.138 sekuntia